Segui

SOLUZIONE: Errore in aggiornamento a Bravo 4.1.0

Sommario

In questo articolo viene spiegata causa e la soluzione all'errore di aggiornamento database che si presenta con l'aggiornamento da una versione precedente di Bravo alla versione 4.1.0.

Premessa

Per una corretta consultazione di quanto segue, occorre avere prima letto l'articolo Come installare Bravo Manufacturing.

Sintomi

In fase di aggiornamento da una versione precedente di Bravo alla versione 4.1.0, durante lo step di aggiornamento del database viene visualizzato il messaggio di errore:

SQLScriptExecuter module
Database:bravodb_X
Per la tabella o vista indicizzata 'BM_ScadaServers' non è disponibile un indice full-text oppure l'utente no dispone dell'autorizzazione necessaria per eseguire questa operazione.
File: C\Users\<Nome Utente>\AppData\Local\Temp\Antos\sql\update-4_0_3_0.sql 

Immagine01.png

Causa

L'errore si rileva solo se in precedenza è stato eseguito l'aggiornamento da una versione 3.9.x o precedente alla versione 4.0.0 o successiva.
L'errore non si presenta quando si crea una nuova installazione di Bravo, si presenta solo in fase di aggiornamento in base alla condizione indicata sopra.
Il problema è determinato da un errore con uno script di aggiornamento di una precedente versione di Bravo.

Soluzione

Per risolvere il problema di aggiornamento del database, dopo che è stato rilevato, occorre eseguire queste azioni:

  1. posizionarsi sul server dove si sta installando l'aggiornamento di Bravo;
  2. aprire il SQL Management Studio e connettersi all'istanza SQL dove si trova il database di Bravo;
  3. nel menù laterale espandere le voci [Istanza SQL > Database > "Database di Bravo" > Archiviazione > Cataloghi full-test];
  4. premere una volta con il tasto destro del mouse sulla voce "BM_AlleantiaScadaServer_FullText" e poi sulla voce per eliminarlo;
    Immagine02.png
  5. confermare l'eliminazione;
  6. eseguire il comando allegato "Drop_full_text_catalogs.sql" allegato in fondo a questo articolo;
  7. chiudere il SQL Management Studio;
  8. riprendere e completare l'aggiornamento di Bravo.

Le azioni sopra citate possono essere eseguite anche preventivamente prima di lanciare l'aggiornamento di Bravo, così da evitare che l'errore si possa presentare.
Se le indicazioni della soluzione vengono applicate in modo preventivo, durante il punto 4, il catalogo potrebbe essere collegato alla tabella. In questo caso deve essere rimosso l'indice.
Si potrebbe eseguire la procedura in ogni caso, anche se non si viene da un update da versioni precedenti la 3.9.2.
Per rimuovere l'indice occorre:

  1. premere con il tasto destro del mouse  sul catalogo e poi premere sulla voce "Proprietà";
  2. premere su "Tabelle/Viste";
  3. rimuovere le colonne abilitate nella parte sottostante;
  4. rimuovere la tabella assegnata al catalogo;
  5. premere su "OK";
    Immagine03.png
  6. viene eliminato il catalogo.

 

Altre domande? Invia una richiesta

Commenti

Powered by Zendesk