Segui

Trasferimento dati da Mago.Net a Bravo

Sommario

Nel presente articolo viene illustrato come eseguire il trasferimento dati di produzione da Mago.Net a Bravo, utilizzando l'apposito gate di interfacciamento tra i due software che si installa su Mago.Net, cioè il Bravo Gate.

Tramite questa operazione le anagrafiche delle risorse (squadre, operazioni, macchine ...) e gli ordini di produzione lanciati in produzione vengono trasferiti da Mago.Net a Bravo per poi essere consuntivati in fabbrica.

 

Quali impostazioni eseguire su Mago.Net prima di lanciare il trasferimento dati

Di seguito vengono illustrate le impostazioni da eseguire sul Bravo Gate di Mago.Net prima di lanciare il trasferimento dati verso Bravo:

1) andare in [Bravo Gate > Documenti Bravo > Anagrafica Console]

2) premere sul pulsante "Nuovo"

3) indicare un codice e una descrizione a libera scelta per la console (la console identifica il reparto produttivo dell'azienda)

4) nella scheda "Centri di lavoro" indicare riga per riga le anagrafiche dei centri di lavoro che sono presenti nel reparto produttivo dell'azienda, la procedura esporta solo gli ordini di produzione nelle cui fasi sono presenti centri di lavoro impostati in anagrafica della console

5) nella scheda "Matricole" indicare riga per riga le anagrafiche delle matricole che sono presenti nel reparto produttivo dell'azienda, la procedura esporta sole le anagrafiche delle matricole che sono indicate in questo elenco

6) salvare l'anagrafica della console

7) andare in [Bravo Gate > Impostazioni > Parametri]

8) premere sul pulsante "Nuovo" se non sono mai stati settati i parametri del Bravo Gate, oppure premere sul pulsante "Modifica"

9) posizionarsi nella scheda "Consuntivazione" ed impostare nel campo "Sincronizza con" la voce "Bravo Manufacturing"

10) posizionarsi nella scheda "Esportazione" ed impostare nel campo "Console" la console creata in precedenza

11) posizionarsi nella scheda "Esportazione" ed impostare nel campo "Numero delle ultime esportazioni da mantenere storicizzate" un valore diverso da 0, di solito si imposta che vengano conservate le ultime 10 esportazioni, così ai successivi lanci, vengono cancellate le esportazioni più vecchie

12) nella scheda "Esportazione" nel riquadro "Filtri esportazioni differenziali dati modificati negli ultimi N giorni" è possibile parametrizzare per ogni tipologia di dati un intervallo di tempo in giorni di esportazione differenziale, per esempio è possibile trasferire su Bravo solo l'anagrafica degli articoli creati/modificati negli ultimi N giorni, al fine di ottimizzare i tempi e la quantità di informazioni trasferite; al primo trasferimento non deve essere impostata nessuna esportazione differenziale in modo che tutte le anagrafiche utili vengano trasferite su Bravo, poi per i successivi lanci è consigliabile indicare dei tempi di esportazione differenziale, di solito si impostano 30 giorni, ma l'impostazione è a discrezione dell'utente

NOTA BENE: La prima esportazione dati, non essendo differenziale può impiegare del tempo per esportare i dati.

13) salvare le impostazioni premendo sul pulsante "Salva"

14) andare in [Bravo Gate > Anagrafiche > Causali > Causali Materiali]

15) creare una nuova causale di consuntivazione materiali (questa viene utilizzata per consuntivare i materiali su Bravo), i dati da indicare sono i seguenti:

  • - "Causale" -> Consumo
  • - "Descrizione" -> Consumo
  • - "Azione" -> Consuntiva Bdp
  • - "Tipo scarico" -> Consumo

16) salvare l'anagrafica della nuova causale di consuntivazione materiali premendo sul pulsante "Salva"

17) andare in [Bravo Gate > Impostazioni > Impostazioni di default materiali]

18) premere sul pulsante "Nuovo" se non sono mai stati settati i parametri del Bravo Gate, oppure premere sul pulsante "Modifica"

19) impostare nel campo "Consumo" la causale precedentemente creata

20) salvare l'impostazione premendo sul pulsante "Salva"

 

Quali impostazioni eseguire su Bravo prima di lanciare il trasferimento dati

Di seguito vengono illustrate le impostazioni da eseguire su Bravo prima di lanciare il trasferimento dati verso Bravo:

1) andare in [Amministrazione > Parametri Azienda > Console]

2) impostare il codice e la descrizione della console creata in precedenza su Mago.Net

3) premere sul pulsante "Salva informazioni"

4) andare in [Strumenti > EasyGate Launcher]

5) selezionare nel campo a tendina "Repository corrente" la voce "MagoIN"

6) premere sul pulsante "Configura package"

7) selezionare una alla volta le voci presenti ed impostare il relativo "Valore" premendo sul pulsante "Modifica" (pulsante con l'immagine di una matita):

  • "BRAVO_DBHOST" -> Nome del server SQL dove è presente il database di Bravo
  • "BRAVO_DBNAME" -> Nome del database di Bravo
  • "BRAVO_DBPASS" -> Password di accesso all'istanza SQL dove è presente il database di Bravo
  • "BRAVO_DBINST" -> Nome dell'istanza SQL dove è presente il database di Bravo
  • "GATE_DBHOST" -> Nome del server SQL dove è presente il database di Mago.Net
  • "GATE_DBNAME" -> Nome del database di Mago.Net
  • "GATE_DBPASS" -> Password di accesso all'istanza SQL dove è presente il database di Mago.Net
  • "GATE_DBINST" -> Nome dell'istanza SQL dove è presente il database di Mago.Net

NOTA BENE: E' molto importante che i nomi sopra indicati siano inseriti correttamente e senza errori.

8) premere sul pulsante "Chiudi"

 

A questo punto sono state eseguite tutte le impostazioni necessarie per consentire il trasferimento dati di produzione da Mago.Net a Bravo.

 

Come eseguire l'esportazione dati da Mago.Net

Seguire le indicazioni sotto riportate per esportare i dati di produzione da Mago.Net:

1) andare in [Bravo Gate > Procedure > Stampa / Esportazione lavorazioni]

2) indicare un codice di "Elaborazione"

3) utilizzare i filtri nella scheda "Filtri su fasi" per selezionare gli ordini di produzione lanciati in produzione da esportare su Bravo per essere consuntivati

4) premere sul pulsante con la sfera verde per avviare l'estrazione dati

5) verificare gli ordini di produzione selezionati nella scheda "Selezione Odp"

6) premere sul pulsante "Accoda" per avviare l'esportazione dati verso Bravo

7) al termine dell'esportazione viene visualizzato un messaggio di avviso

8) chiudere la maschera della procedura.

NOTA BENE: La procedura di esportazione dati da Bravo Gate su Mago.Net prepara i dati per l'esportazione e li salva su delle tabelle di "frontiera" nel database di Mago.Net da dove vengono poi prelevati per essere importati su Bravo, vedi procedura nel prossimo paragrafo.

 

Come eseguire l'importazione dati su Bravo

Seguire le indicazioni sotto riportate per importare i dati di produzione su Bravo:

1) andare in [Strumenti > EasyGate Launcher] 

2) selezionare nel campo a tendina "Repository corrente" la voce "MagoIN"

3) premere sul pulsante "Esegui trasformazioni" per avviare l'importazione dati

4) al termine dell'elaborazione viene visualizzato un messaggio di avviso

5) premere sul pulsante "Ok"

6) chiudere la maschera della procedura

NOTA BENE: La procedura di importazione dati su Bravo, importa una sola esportazione dati da Bravo Gate alla volta.

 

Altre domande? Invia una richiesta

Commenti

Powered by Zendesk