Sommario
Di seguito viene spiegato come risolvere il problema di avvio del servizio BravoEngine che impedisce il funzionamento del prodotto.
Premessa
Per una corretta comprensione delle nozioni di seguito riportate, occorre aver prima consultato l'articolo La configurazione del database e dei servizi di Bravo Manufacturing.
Sintomi
Si rileva che Bravo non funziona in nessuna postazione e controllando sul server dove è presente la sua installazione principale di riscontra che il servizio BravoEngine è arrestato anziché essere avviato e provando ad avviarlo, dopo qualche istante di attesa, il servizio è sempre fermo e viene visualizzato il messaggio di errore:
Il tempo massimo è scaduto e l'operazione non è stata completata.
in System.ServiceProcess.ServiceController.WaitForStatus(ServiceController
Status desiredStatus, TimeSpan timeout) in
BravoServicesController.Helpers.ServiceHelper.Start(ServiceController
controller, String[] args)
Causa
Il servizio non si avvia perché dei settaggi sono assenti all'interno di un file di configurazione nell'installazione principale di Bravo sul server.
Questa mancanza di settaggi è stata riscontrata a volte a seguito di aggiornamenti passando da una versione 3.x a una versione 4.x.
Soluzione
Di seguito sono riportate le indicazioni da seguire per risolvere il problema:
- posizionarsi sul server dove è installato Bravo;
- aprire il percorso "C:\Program Files (x86)\Antos\BravoEngine" (percorso di default);
- individuare il file "hostsettings.json" ed aprirlo con un editor di testo, come per esempio il Blocco Note di Windows;
- se il file risulta avere queste impostazioni:
allora non è configurato in modo corretto, in quanto mancano delle configurazioni, che sono mostrate di seguito sottolineate in rosso:
- si deve quindi creare un duplicato del file come copia di sicurezza e metterlo da parte in una cartella a libera scelta;
- poi si deve modificare il file originale andando ad inserire i parametri mancanti; devono essere riportati fedelmente come mostrato nell'immagine sopra di esempio;
- essendo un file contenuto nel percorso "C:\Program Files (x86)\Antos\BravoEngine" è possibile, che anche se si è loggati su Windows con un utente amministratore, al salvataggio della modifica al file, venga visualizzato che non vi sono i permessi sufficienti per salvare; in questo caso si deve salvare il file in un altro percorso e poi copiare il nuovo file sopra al precedente, confermando il messaggio di sovrascrittura del file;
- chiudere tutte le maschere;
- riprovare ad avviare il servizio BravoEngine e verificare che si avvii correttamente.
Commenti